Friday, December 4, 2009

More Christmas Program Videos

You can read my post about Owen's Christmas program below. I found a quicker way to upload the vids, but unfortunately it didn't allow me to put them into my original post... Make do, okay? :)

Thursday, December 3, 2009

We Wish you a Merry Christmas!

Tonight was Owen's Preschool Christmas program. It was perhaps the most adorable thing that I've ever seen. Owen was NOT excited about this little ordeal. Before his nap today, he yelled from his bed, "I don't like programs!" Repeatedly. Over and over.



When we got there, we let him sit with us for a little while, and then once most of the kids were on the risers, I walked, (drug) him to join his class. He began to protest, but there was *talk* of going to bed with no dinner, and other idle threats... :)



I finally convinced him to join the group, and he was totally fine once he was there. Once the program began, he kind of just stood there looking dazed**. The poor child stood with his back to the audience for two whole songs. I do not however, think that he stood out one bit! The two children on either side of him were... Exuberant- to say the least ;)



Owen certainly had quite the turnout for his debut. Jodi, Brett, Sara, Todd, Grandma, and Grandpa all showed up for his performance (or lack thereof). He had a nice little cheering section!











**A side note that I should probably explain to those who weren't there to witness it, is that Owen was indeed drugged before the start of his program. Yesterday, he had a pretty bad allergic reaction to something (We're thinking red food dye) and so we've been having to give him Benadryl to keep his hives to minimum.


So without further ado, here are some clips (Okay, one clip for the moment... I'll post some more later!) from Owen's first Christmas program!




video

Sunday, November 29, 2009

Comments

I had been hearing for awhile from several people that they were unable to comment on the blog. I couldn't figure it out for the longest time, but I finally realized that I had the settings wrong. It should be fixed now, so please make my day and leave me a comment :)